分析演示:RIP动态路由协议引发的HSRP收敛问题

  • 时间:
  • 浏览:3

演示目标:

1 动态路由协议在并是否程度上能 不上能 帮助HSRP收敛无跟踪的盲点

2 动态路由协议RIP肯能引发HSRP收敛的间题

3 为那先 同一子网的主机,时候 收敛快,时候 慢?

演示环境:如图1所示的环境

背景说明:从实践的时延来讲,在不上能 部署HSRP进行三层冗余的环境中,通常物理链路也是成环的,没法 时候 环境中,进行网络设计时不上能 有点硬注意动态路由协议的确定,以及评估和预测肯能引发的各种收敛间题,明确到底是HSRP在为用户网络在实现冗余,还是三层的动态路由协议在为用户实现冗余,肯能发生收敛间题,比如:收敛慢,是那先 原因原因间题的发生,以及何如对那先 间题进行修复。

演示步骤:

***步:在如图1所示的网络环境中为所有的三层设备启动RIPv2的动态路由协议,具体配置如下所示,确保各个路由器的动态路由学习正常,这是整个演示环境的基础保障。

路由器R1的RIP配置:

R1(config)#routerrip

R1(config-router)#noauto-summary

R1(config-router)#version2

R1(config-router)#network 192.168.1.0

R1(config-router)#network 192.168.4.0

R1(config-router)#network 172.16.0.0

R1(config-router)#exit

路由器R2的RIP配置:

R2(config)#routerrip

R2(config-router)#version2

R2(config-router)#noauto-summary

R2(config-router)#network 192.168.2.0

R2(config-router)#network 172.16.0.0

R2(config-router)#exit

路由器R3的RIP配置:

R3(config)#routerrip

R3(config-router)#version2

R3(config-router)#noauto-summary

R3(config-router)#network 192.168.1.0

R3(config-router)#network 192.168.4.0

R3(config-router)#network 192.168.2.0

R3(config-router)#network 200.200.200.0

R3(config-router)#exit

完成上述配置后路由器R1的路由器表如图2所示。

注意:在R1的路由表包含第每根暂时没法 显示,被隐藏的到 200.200.200.0的RIP路由,这条路由器R1通过下一跳是R2的172.16.1.2来到达200.200.200.0的路由,它为那先 会被隐藏,肯能RIP以跳数来评估路由的度量,通过192.168.4.3和192.168.1.3是1跳,而经过R2的172.16.1.2来到达200.200.200.0的路由是2跳,太多太多它暂时被隐藏,没法 在并是否情况汇报下该路由器会再次无缘无故出现,那太多太多下一跳192.168.4.3和192.168.1.3这两条路由失效时,到此为上边的间题做出了预设。

现在将路由器R1和R2的E1/0接口规划到HSRP热容组1,虚拟IP地址是172.16.1.254,要求R1为活动路由器,并配置两台路由器的抢占功能,具体配置如下所示:

注意:暂时不去配置任何接口跟踪!

路由器R1的HSRP配置:

interface Ethernet1/0

ipaddress 172.16.1.1 255.255.255.0

standby1 ip 172.16.1.254 * 配置HSRP的虚拟IP地址

standby 1 priority 110 * 配置优先级为110,确保R1成HSRP组中的活动路由器

standby 1 preempt * 配置抢占功能

路由器R2的HSRP配置:

interface Ethernet1/0

ipaddress 172.16.1.2 255.255.255.0

standby 1 ip 172.16.1.254

standby 1 preempt

为那先 不为R2配置优先级?

默认优先级为200,为了确保能让R1(优先级110)成为活动路由器,太多太多没必要去配置R2的优先级,使用保持默认的200。

提出有3个 间题:现在到***步的配置为止,肯能路由器的S2/0和E1/1端口再次无缘无故出现故障,请问HSRP的活动路由器是否会从R1切换到R2,流量是否会被R2所接管,在主机上能 不上能 成功的ping通200.200.200.1?

第二步:在路由器R1上制造故障去shutdown路由器R1的S2/0和E1/1接口

R1(config)#intes2/0

R1(config-if)#shutdown *关闭S2/0

R1(config-if)#exit

R1(config)#intee1/1

R1(config-if)#shutdown *关闭E1/1

R1(config-if)#exit

系统提示:有3个 接口的管理属性为down!

*Jul 24 11:24:11.047: %LINK-5-CHANGED: InterfaceSerial2/0, changed state to administratively down

*Jul 24 11:24:11.055: %LINEPROTO-5-UPDOWN: Lineprotocol on Interface Serial2/0, changed state to down

当路由器R1的S2/0和E1/1故障后,如图3所示,故障成功被切换,上边发生多少丢包是肯能切换故障的延迟所致,时候 HSRP冗余组中的活动路由器还是R1,备份路由器是R2,事实上,HSRP的角色情况汇报并没法 改变,太多太多路由协议来帮助用户完成了故障转移,暂且HSRP的功劳。

具体分析如下:

首先在***步完后 ,上能 否在R1上通过show standby brief查看HSRP的信息,如图4所示,可看出,R1仍然是活动路由器,即便是R1的S2/0和E1/1关闭,时候 肯能HSRP并没法 配置track跟踪接口功能,太多太多关闭接口的行为不用造成HSRP的角色转换。没法 此时的流量是何如被R2接管?那是肯能RIP动态路由协议帮助用户网络收敛。

在R1上通过show ip route指令查看路由表,如图5所示,肯能R1的S2/0和E1/1故障,太多太多通过这两条链路的路由会随故障的发生而收敛,消失在R1的路由表中,此时,具备2跳度量值的哪条路由(通过R2到200.200.200.1)会再次无缘无故出现在路由表中,没法 R1就上能 否将主机发来的流量转向投递到R2,时候 由R2发送到R3上的200.200.200.1,具体的证据如图6所示,肯能用户在主机上跟踪到200.200.200.1的路径,好难看出,主机首先仍然将流量转发给活动路由器R1,时候 R1再转发给R2,R2***转给目标。

路由协议去替代HSRP接管故障,切换流量的好处是网络上能 否依赖于动态路由协议的收敛来完成故障转移,真是这也是各大厂商推荐的并是否方案,不足英文之处太多太多不同的动态路由协议的收敛传输时延不同,肯能会为网络造成更大的收敛延迟,关于时候 点上边会有实验来证明;另外它对于HSRP的初学者而言,肯能造成对技术知道点的混淆,比如:没法 配置跟踪track功能,不上能 收敛没法 跟踪功能还有那先 意义。

第三步:肯能此时不用路由器R1的E1/0接口从R2学200.200.200.0的路由,没法 动态路由协议RIP将无法替代HSRP帮助用户去接管故障。先恢复在R1上切断的有3个 接口,等待RIP再次收敛,还原到如图7所示。

为了阻止RIP通过R2去替代HSRP的故障接管,在路由器R1上使用路由过滤列表来阻止路由器R1从连接R2的E1/0接口学习到200.200.200.0的路由,具体配置如下:

在路由器R1上配置路由过滤列表:

R1(config)#access-list 1 deny 200.200.200.0 0.0.0.255 *使用ACl拒绝200.200.200.0

R1(config)#access-list 1 permit any * 允许其它网络

R1(config)#router rip

R1(config-router)#distribute-list 1 in e1/0 * 将ACL列表1应用到RIP任务管理器E1/0的入站上

R1(config-router)#exit

肯能此时再次去切断路由器R1的S2/0和E1/1,动态路由协议RIP再也无法帮助用户完成收敛,去接管用户流量,而当前的HSRP并没法 配置track功能,没法 去跟踪内外部接口S2/0和E1/1的情况汇报,当有3个 内外部接口关闭后,HSRP情况汇报不用改变,不用让R2接管R1成为活动路由器,太多太多主机将无缘无故丢包,如图8所示。

第四步:首先请使用no shut指令再次恢复R1上的有3个 接口(S2/0和E1/1),时候 配置路由器R1的HSRP去跟踪S2/0和E1/1。使用HSRP的接口跟踪功能去替代路由收敛的故障接管行为,具体配置如下所示:

配置路由器R1的接口跟踪功能:

R1(config)#intee1/0

R1(config-if)#standby1 track s2/0 5 * 跟踪S2/0接口,肯能故障优先级减5

R1(config-if)#standby1 track e1/1 20 * 跟踪E1/1接口,肯能故障优先级减20

R1(config-if)#exit

从实践的时延来讲为那先 在跟踪有3个 不同接口总要作出没法 的优先级设计?

从实验环境好难看出,路由器R1的S2/0是第每根减速运动运动时运动链路,R1和R2的以太网链路具备同等的收发传输时延,就即便是R1的S2/0故障,R1也和R2具备相同的发送传输时延,太多太多没必要S2/0故障后,进行HSRP的角色转换(将R2活动路由器),太多太多使用standby 1 track s2/0 5指令申明当S2/0故障后,HSRP的优先级只减少5,没法 R1就会从没法 的优先级110,变为105,仍然高于路由器R2的优先级200,太多太多R1仍然会是HSRP冗余组中的活动路由器。

路由器R2是不用接管故障,断续充当备份路由器的角色,没法 做的***实践是,省去了收敛时发生丢包的肯能。

肯能R1的E1/1接口故障,效果就完正不同,肯能R1的E1/1故障,即便是S2/0仍然存活,肯能不将HSRP冗余组的路由器进行角色转换(将R2转为活动路由器),没法 整个企业网络的流量都将通过R1的减速运动运动时运动链路S2/0进行转发,没法 会原因链路的利用率下降,太多太多使用指令standby 1 track e1/1 20申明,跟踪R1的E1/1,肯能E1/1故障,没法 优先级将下降20,从没法 的110变为90,没法 些时R2的优先级200就高于R1的90,没法 R2将接管故障,成为HSRP冗余组中的活动路由器,流量将切换到R2进行转发。

完成上述的配置后,上能 否通过指令Show standby来查看R1当前的优先级、各个跟踪链路优先级的递减值,如图9所示。

第五步:通过制造R1的E1/1故障的间题来验证R2接管故障的事实,如下所示的配置,在路由器R1上切断E1/1接口。

R1(config)#intee1/1

R1(config-if)#shutdown

R1(config-if)#exit

系统提示:跟踪情况汇报E1/1从up转为down。

*Jul 24 11:43:52.967: %TRACKING-5-STATE: 2 interfaceEt1/1 line-protocol Up->Down

时候 在路由器R1上执行show standby查看当前HSRP冗余组的情况汇报,如图10所示,可就看E1/1的情况汇报为down,优先级减少20,当前优先级为90,活动路由器为R2。时候 在主机上执行路由跟踪,如图11所示,可就看流量通过R2(172.16.1.2)转发。

动态路由协议RIP引发HSRP的慢收敛间题:

注意在本实验环境的第五步中,当路由器R1的E1/1发生故障,172.16.1.0/24子网的主机在做故障切换时,有帕累托图主机肯能会很肯能会收敛很慢了 如图12所示,而另一部则收敛快一点 ,现在不上能 来理解清楚目标是:

1 那先 主机收敛慢,那先 主机收敛快,这是为那先 ?

2 是那先 原因原因收敛慢?

首先来分析当路由器R1的E1/0故障后,肯能HSRP的冗余跟踪了该接口太多太多会立即触发HSRP的故障切换,此时R2会成为HSRP组中的活动路由器,172.16.1.0到200.200.200.0的流量将如图13所示通过R2到达,这是不可质疑的,太多太多去往200.200.200.0的通信流量很顺利。造成长时间(大约1200秒)的收敛的原因主要再次无缘无故出现在200.200.200.0返回给172.16.1.0网络的通信过程中。

众所周知的有3个 事实,RIP的收敛无缘无故都是一件非常令人头痛的间题,有点硬是非本地直连接口故障后,路由表中的相关记录要守侯invalid(无效定时器)超时,默认情况汇报下1200S,这条故障的路由才会从路由表中消失,以该本环境为例,当路由器R1的E1/1接口故障,路由器R3的路由表中“172.16.1.0 255.255.255.0 192.168.1.1”这条路由要等待1200秒左右,也太多太多3分钟才会从表中消失,如图15所示,没法 在这3分钟左右整个网络将发生那先 样的事件呢?

如图14所示,200.200.200.0的返回目标172.16.1.0网络的通信流量时,在1200秒内将在三条路径上进行负载均衡,肯能故障的链路R3的E1/0,肯能“172.16.1.0 255.255.255.0192.168.1.1”这条路由没到1200秒,还发生于路由表中,所有只太多太多通过“172.16.1.0255.255.255.0 192.168.1.1”这条路由返回给目标172.16.1.0的数据总要再次无缘无故出现丢包,时候 时间在三分钟左右,收敛慢。

这将进一步引出有3个 间题:172.16.1.0主机在故障切换的时候 过程中,时候 主机故障收敛较快,丢包很少,时候 主机收敛很慢了 ,会有长达3分钟左右的丢包,关键是那先 主机收敛快,那先 主机收敛慢,这是为那先 原因?

这被R3的ip cef的负载均衡模式所决定,在R3上RIP没法 收敛的1200秒内, 路由表还维系在如图15所示的情况汇报下,200.200.200.1将仍然使用“172.16.1.0 255.255.255.0192.168.1.1”这条路由来返回流量给172.16.1.0,默认情况汇报下R3的ip cef的负载均衡土法律办法是:肯能发生多条路径(本环境包含三条),没法 200.200.200.1将根据不同的目标主机来完成负载均衡,为了方便理解,举一实例来说明:如图16所示,当流量从200.200.200.1返回给172.16.1.0网络时,172.16.1.0网络的主机太多太多目标,没法 R3的ip cef决定根据不同的目标主机使用三条路径来完成负载均衡,此时的172.16.1.101、172.16.1.200、172.16.1.102三台主机太多太多有3个 不同的目标,肯能到目标172.16.1.101使有E1/1返回流量,没法 收敛快;肯能到目标172.16.1.200使有S2/0返回流量,收敛也快,肯能这两条链路都是稳定的不用上能 RIP作收敛,时候 到目标172.16.1.102在1200S内就会再次无缘无故出现持续的丢包,收敛慢,直到故障路由从R3的路由表中消失,如图17所示,不上能 顺利完成收敛。当然管理员上能 否在R3上通过clear iproute *来强制初始化R3的路由表,上能 否提高收敛的传输时延,时候 时候 除理方案过于极端,有点硬是在工业生产环境中,是不建议没法 做的。

通过上述的分析与实验取证,村里人 应该不用上能 体会到有3个 事实:往往有3个 网络间题肯能故障暂且是某有3个 技能知识点所引发,它肯能是藏于有3个 知识点的身前,也肯能是多个知识点进行集成应用时发生的,建议村里人 在网络工程领域始终暂且以“有3个 点”的土法律办法来看待发生的间题,应该进行联动分析,综合取证。

以该环境为例,村里人 就看了矢量路由协议在实战应用环境中的确如各个设备生产商所述的收敛是有3个 很大的间题,没法 在该环境中,来使用静态路由去替代RIP并接合HSRP来完成冗余部署是否会有更好的效果,就自己看来间题更严重,肯能不建立预设分析,没法 用户将永远告诉我将生那先 ,发生的原因,及何如除理?

【编辑推荐】

【责任编辑:

蓝雨泪

TEL:(010)684762006】



点赞 0